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What is data analysis?

çData analysis involves sorting through massive amounts of 

unstructured information and deriving key insights from it, which are 

enormously valuable for decision-makingè.

An overview of how data analysis is done:

Define the question or goal behind the analysis: what are you trying to

discover?

Collect the right data to help answer this question.

Perform data cleaning/data wrangling to improve data quality and prepare it

for analysis and interpretation.

Manipulate data using Spreadsheets (such as Excel).

Analyze and interpret the data using statistical tools (i.e. finding correlations,

trends, outliers, etc.).

Present this data in meaningful ways: graphs, visualizations, charts, tables,

etc.



We use Excel for:

Entering, storing, organizing, analyzing different kinds of data.

Representing data in a variety of ways, with visually interesting charts and

graphs (e.g. in bar graphs, line graphs, and scatterplots).

Performing calculations with mathematical and statistical functions.

Introduction to Excel (1)

çExcel is one of the most popular spreadsheet applicationsè.

çA Spreadsheet is a grid of rows and columns in which you enter text, 

numbers, as wells as the results of calculationsè.



Introduction to Excel (2)

Advantages of Excel (and spreadsheets in general):

The space allowed to the user by the ñspreadsheetòis unlimited.

Information is organized and is easy to access.

Information is easy to edit if a mistake has been made by retyping or using

ñundoò.

Data can be quickly analyzed.

Data can be easily sorted and filtered.

Calculations are completed automatically.

Calculations are correct.

Reports can be made more visual by using charts and graphs.



Opening Microsoft Excel (1)

To open Excel and create a Workbook:

Start menu > All Programs > Microsoft Office > Excel (or ñSearchòExcel).

File > New > Blank Workbook.

Workbook

The file (with 

extension .xls or 

.xlsx) used to 

store various 

Excel sheets, 

which are called 

worksheets.



Opening Microsoft Excel (2)

To open Excel and create a Workbook:

Start menu > All Programs > Microsoft Office > Excel (or ñSearchòExcel).

File > New > Blank Workbook.

Workbook

The file (with 

extension .xls or 

.xlsx) used to 

store various 

Excel sheets, 

which are called 

worksheets.



Opening Microsoft Excel (3)



Saving a document

To save an Excel file (Workbook):

File > Save as.

In a dialog box, you can specify: 1) the new fileôsname, 2) location of where

you want it saved, and 3) format of the document.

Press ñSaveòbutton in the dialog box.

Donôtforget to periodically save your work as insurance against a computer

freeze or a power outage (click the ñsaveòbutton).

Saving dialog box
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1. The area outlined in yellow is called theñTitle barò - It displays the 

name of the open program (in this case Microsoft Excel) and the 

name of the current file (workbook name).

2. The area outlined in blue is the work area (the active worksheet).

3. The area outlined in green includes the sheet tabs - Here we can 

create worksheets (press ñ+ò) and manage them (choose, change 

name, delete, move).
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About worksheets

We can create new worksheets by pressing theñ+òbutton.

The worksheet displayed in the work area is the active worksheet.

We can delete a worksheet, rename it (double-click and type a new name) or

move it (hold, drag & release mouse).

Also, we can do the previous actions from the pop-up window (right click).

Pop-up
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4. The area outlined in yellow is called ñQuick Access Toolbarò - It

contains the most commonly used commands (Save, Undo, Redo).

5. The area outlined in blue is called ñRibbonò- It depicts all the 

features in easy to understand form (expanded menu) -ñRibbonò

is broken into ñTabsò (Home, Insert, Dataé) & ñTabsò into groups.

6. The area outlined in green is where any calculations or formulas

we write will appear.
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The ñHome TabòGroups contain the commands 

most commonly associated with the formatting 

and editing of cells and their contents.

Number Styles Cells Editing

Clipboard Font Alignment



The ñInsert TabòGroups contain the commands 

most commonly associated with adding 

something to the document.

Charts Tours Sparklines

Filters

Tables Illustrations Add-ins

Links Text & Symbols



The ñPage Layout TabòGroups contain the 

commands most commonly associated with 

settings that affect the entire page or worksheet.

Sheet Options Arrange

Themes Page Setup Scale to Fit



The ñFormulas TabòGroups contain the 

commands most commonly associated with 

Excelôs formulas and functions.

Calculation

Function

Library

Defined

Names Formula

Auditing



The ñData TabòGroups contain the commands 

most commonly associated with data from 

external sources, and evaluating/arranging data.

Data Tools Forecast Outline

Get & Transform Connections Sort & Filter



The ñReview TabòGroups contain the 

commands most commonly associated with text 

portions of a spreadsheet and sharing changes.

Language Comments Protect

Proofing Accessibility Insights



The ñView TabòGroups contain the commands 

most commonly associated with the variety of 

ways you can ñlook atò a worksheet/workbook.

Window Macros

Workbook 

views
Show Zoom



Excel organize information (text and 

numbers) by rows and columns

ÅRows are represented by numbers along the side of the sheet

ÅColumns are represented by letters across the top of the sheet

ÅA cell is the intersection of a row and a column (unique name)

ROW

COLUMN

Cell B9



The Excel Interface



Data entry ïActive cell

To enter information into a cell: Click on a cell, and type in the data

(numbers or text) and press Enter.

The cell in the worksheet in which you can type data is called the active cell.

A border will appear around the active cell indicating that it is a selected cell.

The contents of the active cell always appear in the Formula Bar.

We can change the active cell either by moving the pointer or by using keys.

Data Entry Keyboard navigation

Active Cell



Flash Fill (1)

Excel Flash Fill is a special tool that analyzes the information you are

entering and automatically fills data when it identifies a pattern.

Flash Fill easily copes with dozens of different tasks, such as:

- splitting and combining text strings,

- cleaning data and correcting inconsistencies,

- formatting text and numbers,

- converting dates to the desired format.

The Flash Fill tool resides on theñDataTabò, in theñDataToolsògroup.

You can run Flash Fill with this key combination: Ctrl + E.



Flash Fill (2)

Usually Flash Fill starts automatically, and you only need to provide a

pattern. Here's how:

1. Insert a new column adjacent to the column with your source data.

2. In the first cell of a newly added column, type the desired value.

3. Start typing in the next cell, and if Excel senses a pattern, it will show a

preview of data to be auto-filled in the below cells.

4. Press the Enter key to accept the preview.



Changing data in a cell ïCut, Copy, and Paste

You can edit, replace, or clear data.

You may change an entry within a cell two different ways:

- Click the cell one time and begin typing. The new information will replace any

information that was previously entered.

- Double click the cell and a cursor will appear inside. This allows you to edit

certain pieces of information within the cells instead of replacing all of the data

at once.

You can use the Cut, Copy and Paste features of Excel to change the data

within your worksheet or to move data from other worksheet into new

worksheets.

To Cut or Copy & Paste:

- Highlight the data or text by selecting the cells that they are held within.

- Go to Edit > Copy (Command-C) or Edit > Cut (Command-X).

- Click the location where the information should be placed.

- Go to Edit > Paste (Command-V).



Finding & Replacing data (1) 

You can easily search the worksheet using the ñFindòfeature, which also

allows you to modify content using theñReplaceòfeature.

From the ñHomeTabò, click the ñFind& Selectòcommand, then select

ñFindò(orñReplaceò) (also by pressingñCommand-Fò).



Finding & Replacing data (2) 

You can easily search the worksheet using the ñFindòfeature, which also

allows you to modify content using theñReplaceòfeature.

From the ñHomeTabò, click the ñFind& Selectòcommand, then select

ñFindò(orñReplaceò) (also by pressingñCommand-Fò).



Selecting group of cells

A group of selected cells is called a range - The range is identified by its

range reference, e.g. a) B3:F3, b) A3:C5.

In an adjacent range, all cells touch each other and form a rectangle

- To select an adjacent range, click the cell in a corner of the range, drag the

pointer to the cell in the opposite corner of the range, and release the mouse

button.

A nonadjacent range has two or more adjacent ranges and selected cells

- To select a nonadjacent range, select the first adjacent range or cell, press

the Ctrl key as you select the other cells or ranges you want to include, and

then release the Ctrl key and the mouse button.

B3:F3

A3:C5



Using the fill handle (1)

You can use the ñfillhandleòto quickly copy and paste content to adjacent

cells in the same row or column.

Select the cell(s) containing the content you wish to use - The ñfillhandleò

will appear as a small square in the bottom-right corner of the selected cell(s).

Click & drag the ñfillhandleòuntil all of the cells you wish to fill are selected.



Using the fill handle (2)

You can use the ñfillhandleòto quickly copy and paste content to adjacent

cells in the same row or column.

Select the cell(s) containing the content you wish to use - The ñfillhandleò

will appear as a small square in the bottom-right corner of the selected cell(s).

Click & drag the ñfillhandleòuntil all of the cells you wish to fill are selected.



Rotating rows/columns (1)

When you need to rotate columns and rows, you transpose them in Excel.

Select & Copy the cell(s) containing the content you wish to use - On the

ñHomeTabò, click the arrow under the Paste button.

Click Paste Special, and then click the checkbox for Transpose - Press OK.



Rotating rows/columns (2)

When you need to rotate columns and rows, you transpose them in Excel.

Select & Copy the cell(s) containing the content you wish to use - On the

ñHomeTabò, click the arrow under the Paste button.

Click Paste Special, and then click the checkbox for Transpose - Press OK.



Formatting cells (1)

There are various different options that can be changed to format the cells

differently - When changing the format within cells you must select the cells

that you wish to format.

To get to the ñFormatCellsòdialog box select the cells you wish to change

then press right click and go to Format > Cells - A box will appear on the

screen with 6 different tab options (4 of these are presented below):

ÁNumber: Allows you to change the measurement in which your data is used

(if your data is concerned with money the number that you would use is

currency).

ÁAlignment: This allows you to change the horizontal and vertical alignment

of your text within each cell - You can also change the orientation of the text

within the cells and the control of the text within the cells as well.

ÁFont: Gives the option to change the size, style, color, and effects.

ÁBorder: Gives the option to change the design of the border around or

through the cells.



Formatting cells (2)



Formatting cells (3)



Formatting cells (4)



Formatting cells (5)



Formatting cells (6)



Formatting cells (7)

x2

x2



Formatting cells (8)



Formatting cells (9)

Font Style - Size
BoldïItalicsï

Underline

Add boarders

To change 

horizontal & 

vertical alignment

To add fill & font 

color



Formatting cells (10)



Formatting/Adding rows & columns

When formatting rows and columns you can: (1) change the height (or

width), (2) hide (or un-hide) information within a row or column, or (3)

delete the row/column.

When adding a row or column you are inserting a blank row or column next

to your already entered data - To insert multiple at once, select the number

of rows/columns you would like to insert.

1

2

3
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2

3

Column

Row

Hide

Information



Freezing rows & columns (1)

You may want to see certain rows or columns all the time in your worksheet,

especially header cells.

By freezing rows or columns in place, you'll be able to scroll through your

content while continuing to view the frozen cells.

Click theñViewTabòand go toñFreezePanesò- ChooseñFreezeTop Rowò

from the drop-down menu.

ChooseñUnfreezePanesòto unfreeze rows.



Freezing rows & columns (2)

FREEZE

NO 

FREEZE



Conditional Formatting (1)

Conditional Formatting changes the color of a cell and its contents given a

certain condition.

For example, you might want to highlight any negative numbers in red, or

cells that contain a certain word.

From theñHomeTabò, click theñConditionalFormattingòcommand.



Conditional Formatting (2)

Conditional Formatting changes the color of a cell and its contents given a

certain condition.

For example, you might want to highlight any negative numbers in red, or

cells that contain a certain word.

From theñHomeTabò, click theñConditionalFormattingòcommand.



Conditional Formatting (3)

Conditional Formatting changes the color of a cell and its contents given a

certain condition.

For example, you might want to highlight any negative numbers in red, or

cells that contain a certain word.

From theñHomeTabò, click theñConditionalFormattingòcommand.



Conditional Formatting (4)

Conditional Formatting changes the color of a cell and its contents given a

certain condition.

For example, you might want to highlight any negative numbers in red, or

cells that contain a certain word.

From theñHomeTabò, click theñConditionalFormattingòcommand.



Sorting/Filtering Data (1)

We can sort our data alphabetically, numerically, and in many other ways.

To sort our data alphabetically, select theñHomeTabò, then click Sort & Filter

> Sort A to Z.



Sorting/Filtering Data (2)

We can sort our data alphabetically, numerically, and in many other ways.

To sort our data alphabetically, select theñHomeTabò, then click Sort & Filter

> Sort A to Z.



Sorting/Filtering Data (3)

We can sort our data alphabetically, numerically, and in many other ways.

To sort our data alphabetically, select theñHomeTabò, then click Sort & Filter

> Sort A to Z.



Sorting/Filtering Data (4)

We can sort our data alphabetically, numerically, and in many other ways.

To sort our data alphabetically, select theñHomeTabò, then click Sort & Filter

> Sort A to Z.



Sorting/Filtering Data (5)

Filters can be used to narrow down the data in your worksheet, allowing you

to view only the information you need.

In order for filtering to work correctly, your worksheet should include a header

row, which is used to identify the name of each column.

Select theñHomeTabò, then click Sort & Filter > Filter - A drop-down arrow

will appear in the header cell for each column - Click the drop-down arrow for

the column you wish to filter.



Working with charts (1)

Charts are an important part to being able to create a visual for spreadsheet

data - Showing data in a chart can make it clearer, more interesting and

easier to read.

Once the data are entered, the cells that are going to be used for the chart

need to be highlighted so that the software knows what to include.

Excel provides a variety of chart types that you can choose from when you

create a chart.

V Column charts / Bar charts use vertical / horizontal bars to represent data. They

can work with many different types of data, but theyôreusually used for comparing

information.

V Pie charts make it easy to compare proportions. Each value is shown as a slice of

the pie, so it's easy to see which values make up the percentage of a whole.

V Line charts are ideal for showing trends. The data points are connected with lines,

making it easy to see whether values are increasing or decreasing over time.

V Scatterplots are an excellent way to visually display the relationship (correlation)

between two variables.



Working with charts (2)



Working with charts (3)

Charts:

ÅCharts present information in the form

of graphs, diagrams, maps or tables.

ÅCharts are a large group of methods

for presenting information.

Graphs:

ÅGraphs show the mathematical

relationship between sets of data.

ÅGraphs are one type of chart, but not

the only type of chart.

çIn other words, all graphs are charts, but not all charts are graphsè.



Working with charts (4)

Select the cells you want to chart, including the column titles and row labels.

From theñInsertTabò, click the desired Chart command.

Choose the desired chart type from the drop-down menu.



Working with charts (5)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the ñAddChart Elementòcommand on the

ñDesignTabò, then choose the desired element from the drop-down menu.



Working with charts (6)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the ñAddChart Elementòcommand on the

ñDesignTabò, then choose the desired element from the drop-down menu.



Working with charts (7)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the ñAddChart Elementòcommand on the

ñDesignTabò, then choose the desired element from the drop-down menu.



Working with charts (8)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the ñAddChart Elementòcommand on the

ñDesignTabò, then choose the desired element from the drop-down menu.



Working with charts (9)

Excel allows you to add chart elements -such as chart titles, legends, and

data labels- to make your chart easier to read.

To add a chart element, click the ñAddChart Elementòcommand on the

ñDesignTabò, then choose the desired element from the drop-down menu.



Excel also includes several different chart styles, which allow you to quickly

modify the look and feel of your chart.

To change the chart style, select the desired style from the ñChartStylesò

group.

Working with charts (10)



You can also use the chart formatting shortcut buttons to quickly: (1) add 

chart elements, (2) change the chart style, and (3) filter the chart data.
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3
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Working with charts (11)



2

You can also use the chart formatting shortcut buttons to quickly: (1) add 

chart elements, (2) change the chart style, and (3) filter the chart data.

1

2

3

Working with charts (12)


